Strapi Plugin : not able to fetch collections

Can’t access my strapi with the plugin.
How to find why ?

Hi, one thing that comes to mind, maybe its not working because you dont have SSL on that domain.

You settings inside Strapi should be like this, I guess this is good also on your side?

Hi @xmasrock

You need to allow READ access to your content-types (collections) and it’s fields.
Check out - How to get content types and field list with API? - Questions and Answers - Strapi Community Forum

yes all is ok in strapi

however, my access through https isn’t enabled yet, so I tried with http:// only
Does this can be the reason then?

Have you tried to follow article that Dejan sent, it needs so more options to be enabled in Strapi?
We will also release a tutorial tomorrow for Strapi, so if you wan to wait for that, it might help you if you dont succeed before that.

Thanks @Pakic & @dejan it works with the contentTypa access enabled.

Now, I still can’t see the Strapi source :

One stupid question maybe, did you try to refresh a page? :smiley: Or maybe try to click re-cache in the strapi settings?
Does it show you “cached bases” on strapi settings page?

Thanks mate, refresh has done it.
Is it intentional that only collections are visible an not single type?



We don’t have support for Single Types yet, we can add it in following days.

Thanks @dejan, I’m definitely interested to be notified :slight_smile:

SingleType are especially interesting for landing pages

Hi dejan,

are there any news on implementing Singe Types?

Thanks in Advance