Uploads images work, but only once


I can upload images. The images show, I can use it in builder as well, copied links work. But when I want to add it again (let’s say it’s an icon) the picture cannot be found, it simply doesn’t show in the popup browser window. But the link to it still works.
I’m using Edge, cleared all Divhunt related cache, tried another project, private/incognito window and in another browser - Chrome. Same problem.

I’ve done some more trial and error and noticed that lower resolution images does work. I’m trying to find the breakpoint - if there is anyone :slight_smile:

Just to clarify this, we figured out it’s up to the problem of uploading the same image twice. If the image contains the same metadata, it will read it as the completely same image and generate the same upload link, which causes the problem of the image disappearing from Media Manager.

If you just want to use the icon again (and know the name of the file you uploaded), you can search for it so you won’t upload it again.

Alternatively, if you want to lead up different resolutions of the same phone, a simple workaround for now is to change the file name. I believe this should be enough to have it show up again :).

I just uploaded 16 photos, all showed, I used one photo in the grid, then when I’m about the add the second one - all is gone. Renamed them all before upload.

I renamed images, uploaded again, same result. See video:

Can you please fix this? :blush:

@Vincent @Studio350

Fixed, please test. Might still be a bit buggy, but should do the work. I don’t want spend much time since new Storage application will come in future with folders and much more options etc.

@Studio350 @dejan

Nope, still same error :frowning: Renamed them, uploaded them, exactly the same bug as in the video.

Renamed them again, opened a private window, uploaded them all, could attach one file, open to attach the next - no images there :frowning:

Usually this is not a problem, now it’s bothersome since I’m building wedding galleries with a lot of images :laughing:

Is there an ETA on the updated storage application? :slight_smile:

1 Like


I’ll fix it today, I only tried with single image upload and it worked for me, but will test it more and see what’s going on.

1 Like

I tried different uploads styles and it works now! :heart_eyes:
If I upload the same image, it will show as two, and when I open the box again to attach the same image again, it only shows one. I just assume that it recognize the size and name of it and remove one of the duplicates. In wordpress it just adds -# to the file. I.ex photo.jpg, photo-1.jpg, photo-2.jpg etc if you upload a file with the same filename.

But now I can adds files and they don’t disappear! :smiley:

Awesome work, fast and swift! Thank you so much! :grin::ok_hand:t2:


Will fix that too.

We never double upload same image, we always check the content and size to compare if image is already uploaded, that’s why there was some issues with it.

In this way, we save space by not uploading same images multiple times.

This is so weird. Now when I uploaded 16 images they showed as usual at initial upload, but my “use” button told me I had 21 images selected, de-selected all I could see, still 5 selected. So I closed the window, open it again - all 16 images gone :frowning: This is in the CMS when I try to add multiple images into the “Wedding Info” item I have there.

Also, date picker in the CMS doesn’t work for me, never has. The date is never saved :frowning:


I’ll do more testing tomorrow, must be some hidden bug.


Yeah, I’ll try to find now better date picker library as current is very bad.


I’ve implemented new date picker, tested some and seems that it works much better.

Currently it’s un-styled, let’s have some beta testing first and if user feedback is good, we will use this one.

Tried calendar, it works now! Awesome that you can select time as well! :smiley:

1 Like